Amiga-Development

Please login or register.

Login with username, password and session length
Advanced search  

News:

Created for developers of all Amiga camps

Pages: 1 [2]

Author Topic: icon  (Read 8800 times)

0 Members and 1 Guest are viewing this topic.

adminZRt75

  • Administrator
  • Hero Member
  • *****
  • Posts: 590
    • View Profile
Re: icon
« Reply #15 on: July 27, 2013, 11:34:29 PM »

Thanks a lot for explaining the reason. It's always good to know what's going on (or wrong).
 
Btw, Olaf is working on the transition from "Wanderer" to "Megellan" as Desktop now.
http://amigaworld.net/modules/newbb/viewtopic.php?topic_id=37959&forum=47

short info "Toni" is always Toni Wilen. He programmed and maintains the "ROM Replacements". Aros 68k is maintained by Jason McMullan and both combined is "AROS 68k"
Logged

PeterK

  • Newbie
  • *
  • Gender: Male
  • Posts: 24
    • View Profile
Re: icon
« Reply #16 on: July 29, 2013, 06:45:53 PM »

I'm an idiot and have just wasted a lot of Toni's precious time.  :'(
He wanted to solve my problem with the AROS Version command which I blamed to "FAIL" instead to "WARN". But after some discussions with Toni who could not reproduce this issue I finally noticed that it was not the Version command which brakes the startup-sequence. The message in the shell has fooled me saying "Version SVNxxxx blabla...", but that's just the version of the system. So, if someone is stupid, it's me and not the AROS Version command.
 
All you really need in the second line of your startup-sequence is
 
LoadModule LIBS:icon.library
 
(the version test and the IF / ENDIF are not required for LoadModule unlike for LoadResident)
Logged
Projects: icon.library 46.4, IconBeFast, MemTrailer, TagLiFE, MathLibsUAE and MinStack

adminZRt75

  • Administrator
  • Hero Member
  • *****
  • Posts: 590
    • View Profile
Re: icon
« Reply #17 on: July 30, 2013, 02:24:30 PM »

I'm an idiot and have just wasted a lot of Toni's precious time.  :'(
He wanted to solve my problem with the AROS Version command which I blamed to "FAIL" instead to "WARN". But after some discussions with Toni who could not reproduce this issue I finally noticed that it was not the Version command which brakes the startup-sequence. The message in the shell has fooled me saying "Version SVNxxxx blabla...", but that's just the version of the system. So, if someone is stupid, it's me and not the AROS Version command.
 
All you really need in the second line of your startup-sequence is
 
LoadModule LIBS:icon.library
 
(the version test and the IF / ENDIF are not required for LoadModule unlike for LoadResident)

You really seem to take that too serious. I am very grateful for your help and hope it will not be the last time. AROS 68k needs more support by developers to really replace old AmigaOS in future.
Logged

magorium

  • Full Member
  • ***
  • Posts: 221
  • Programming is an art form that fights back
    • View Profile
Re: icon
« Reply #18 on: July 31, 2013, 03:47:54 AM »

Team Chaos Leader wrote:
Quote
Does someone maintain a list somewhere of all the things in AROS that are incompatible with AmigaOS?
Not exactly. On the reference page and if there are any incompatibilities they should be listed there. But documentation is not finished yet and is a continue work in progress.

I wonder if my programs are broken under AROS too?

We need a program that will go thru all the include files and print out all the intentional incompatibilities that AROS has introduced.
Only one way to find out if your program fails under AROS ;)

I don't think such program will be helpfull. At least Abiv1 should be as compatible as possible with classic amigaOS 3.x (i'm still not 100% sure if that would be 3.1 or 3.9).

Everything else you find not working is either
1) a bug (please report) or
2) not yet implemented (in which case it's on someones todo-list or longterm goal of AROS) or
3) bad coding habbits (f.e. making wrong assumptions on excisting documentation).

Why else people think OlafS3's work to be of importance for AROS ? ;)

red: forgot to add option 3
« Last Edit: July 31, 2013, 04:01:26 AM by magorium »
Logged

PeterK

  • Newbie
  • *
  • Gender: Male
  • Posts: 24
    • View Profile
Re: icon
« Reply #19 on: August 22, 2013, 08:41:19 AM »

Update to icon.library 46.4.322

The color reduction from truecolor to the OS 3.5 format has been improved a little. This should make color banding effects less visible on low resolution screens.  The RGB levels are now pushed up by 131 for every second pixel. This gives a better blue sometimes (instead of purple). All my efforts to use some simple dithering code with spreading the color error could not beat the results of this easy level pushing trick. So, this experiment is finished now.

Changed my pen allocation code for AROS. It sets the -1 marker now to pe_FirstFree when the last free pen was allocated and added to the shared pens.
 
Use LoadModule Libs:icon.library in your startup-sequence somewhere above SetPatch.
Logged
Projects: icon.library 46.4, IconBeFast, MemTrailer, TagLiFE, MathLibsUAE and MinStack

SamuraiCrow

  • Administrator
  • Sr. Member
  • *****
  • Gender: Male
  • Posts: 378
  • Coolness is compiled
    • View Profile
Re: icon
« Reply #20 on: August 22, 2013, 09:19:07 AM »

Good news!
Logged

PeterK

  • Newbie
  • *
  • Gender: Male
  • Posts: 24
    • View Profile
Re: icon
« Reply #21 on: September 15, 2013, 01:41:05 AM »

New icon.library 46.4.326 on Aminet available:
http://aminet.net/package/util/libs/IconLib_46.4
 
It comes with an additional version for the 68000 CPU now.
Logged
Projects: icon.library 46.4, IconBeFast, MemTrailer, TagLiFE, MathLibsUAE and MinStack

Veda

  • Hero Member
  • *****
  • Gender: Male
  • Posts: 1008
  • Sleep is overrated
    • View Profile
Re: icon
« Reply #22 on: September 15, 2013, 09:47:41 AM »

thank you Peter
Logged
Pages: 1 [2]